v1.0.0 mega testing fun!!!

Discussion in 'Testers' started by renlok, Apr 26, 2010.

Thread Status:
Not open for further replies.
  1. paditur

    paditur New Member

    Joined:
    Jul 13, 2009
    Messages:
    606
    Likes Received:
    2
    In the includes folder there is a file called config.inc.php.new. Just remove the .new
     
  2. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    To make this worse I tried to change an auction through Admin which threw errors (that I/we can deal with later) but did change the database entry to say simply "paypal". However, the auction still showed both Paypal and the second payment method (Credit Card in this case).

    Don't know why it would but an old note about the capitalization of the word Paypal on the item page and smaller letter paypal in the database might have something to do with it. I remember it being mentioned in brief without the solution when this bug first appeared.

    Capitalizing it manually in the database (again where only "paypal" appears?) lists only the 2nd payment method on the item page.
     
    Last edited: Nov 12, 2010
  3. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    I take it back about the removal of email_request.php

    I forgot about the potential contact of seller during the paying process which is not connected to any current open auctions.
    This unfortunately is the only form I haven't been able to successfully get Capcha working on. :mad: Have to turn it off for fear of exploitation.

    This an the Paypal issue remain for me, can't seem to get either fixed.
     
  4. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    made a new revision think everything is fixed now
     
  5. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    r.284

    Not sure what your tackling pre-1.0.0 release so not sure what "everything" is so here is a list of the ones I'm aware of and where they stand.

    Recent ones first, think these are what your referring to based on files changed in r.284:
    Choosing Paypal brings 2nd payment with it - partially fixed.
    Paypal selected during sell shows correctly as only Paypal (not with 2nd payment method) during preview but actual auctions still shows both Paypal and 2nd payment method.

    email_request - not fixed.
    Does nothing on send.
    Ultimately needs captcha. Wasn't able to check the name@domain server in "from" & "reply-to" because of no send and other email sends were not edited so assuming still an issue.

    Editing an active auction starts the duration again - fixed

    Payment methods in Admin-Users-View Auctions not populating - fixed but here too shows the 2nd Payment method when Paypal is selected.

    Editing Auctions in Admin throws errors
    - not fixed. I realize I have not reported the error log, waiting until payment method is fixed so that can be tested at the same time.


    Other older ones just to recap everything in one post again, doesn't appear that these were addressed based on effected files:
    Reactivating User persists. Two welcome messages sent.
    Banner issue persists. Only tested category limiting and banners still show outside of those selected category/subcategories. Will test memory issue from selecting all cats. when this one works.
    Future start issue persists.
    RSS issue confirmed fixed
    Email notification issues not tested yet.
    Dutch auction related issues not tested yet.
    Older issues again for reference

    I think that's everything at least that I've reported. Others will need to report for their own.
     
  6. Guest

    Guest Guest

    still errors with update RC5 + svn284

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/dan20605/public_html/auktion/install/update.php:137) in /home/dan20605/public_html/auktion/includes/common.inc.php on line 15
    please delete the install directory

    best regards ole
     
  7. paditur

    paditur New Member

    Joined:
    Jul 13, 2009
    Messages:
    606
    Likes Received:
    2
    Can someone please help me with this error?
    I'm wondering if this error is the reason why I cannot select a category anymore to list an auction and test. I'm sure it has something to do with the host, but I do want to go to them with an intelligent question, and right now I cannot.

    Thanks in advance.

    Using SVN284
     
  8. Southern Holsters

    Southern Holsters New Member

    Joined:
    Oct 31, 2010
    Messages:
    79
    Likes Received:
    8
    Edit and resubmit auction extends out up to a year

    Editing and resubmitting auction now extends the auction from 3 months to a year depending on what the duration is set to. Not changing the duration for a 30 day auction moves the end date out 3 months. One I changed from 30 days to, I believe a week, and it extended it out a year.

    My max auction duration set in Admin is 30 days.
     
  9. Southern Holsters

    Southern Holsters New Member

    Joined:
    Oct 31, 2010
    Messages:
    79
    Likes Received:
    8
    Just confirming a couple of items.
     
  10. Guest

    Guest Guest

    Mails is empty SVN 284 (Solved)

    i use the resend e-mail in users. and the mails get tru butm they is empty.

    _Best regards ole

    Sorry my mistake had missed subfolder in the language folder :eek:
     
    Last edited by a moderator: Nov 25, 2010
  11. Southern Holsters

    Southern Holsters New Member

    Joined:
    Oct 31, 2010
    Messages:
    79
    Likes Received:
    8
    Renlok,

    Found a mistake in SVN 285.

    " ) " was left off of line 89 in functions_user.php. in SVN 285. Instead of it being:

    Code:
    'BALANCE' => $system->print_money($this->user_data['balance'], true, 
    it should be:

    Code:
    'BALANCE' => $system->print_money($this->user_data['balance'], true[B][COLOR="red"])[/COLOR][/B], 
     
  12. Southern Holsters

    Southern Holsters New Member

    Joined:
    Oct 31, 2010
    Messages:
    79
    Likes Received:
    8
    "Buy Now Only" auction email received by the seller shows the "Starting Bid Amount" and "Reserve Price." Those items should not be there as they are irrelevant to the auction and may cause confusion for the seller.
     
  13. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    Done some more bug fixes

     
  14. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    Great! I'll start later today.

    Lol about the user email. That might very well be the case, can't remember the user I tested with.

    Future start bothers me. I think it's still there but depends on the day and time you select and doesn't work with all of them. :confused:

    Anyone testing can you please test setting an auction to start in the future (pending) and report back with what happens?
    If it does work for you please pay careful attention to the date you enter and the date shown during review/listing and make sure they agree. Finally of course make sure it goes to pending and does not start. Try a date and time just slightly into the future and not way out.

    Try removing the start date/time all together. (based on my tests this will list a closed auction)

    Also can anyone please try a number of combinations of days/times. Some close to your current time, some further out.

    Also pay attention to the date. Sometimes if there is an error on the initial sell page the refresh for me changes the format of the date to mm/dd. This same date shows if you put the auction just a couple of hours in the future.

    Finally click back and forth to "make changes".

    Lol, in other words try a lot of scenarios.
     
    Last edited: Nov 29, 2010
  15. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    Confirmations, notes carried forward and Future Start testing and images

    r.286 Another good one fixing multiple issues!

    Choosing Paypal brings 2nd payment with it
    - Working fine. True :D.

    email_request - not fixed. Issue persists with regards to server in headers. As suggested probably add captcha and pre-populate with users email.
    Email does get sent. :D

    Recap:
    Ultimately needs captcha. Wasn't able to check the name@domain server in "from" & "reply-to".

    Payment methods in Admin-Users-View Auctions not populating - Working fine. True :D.

    Editing Auctions in Admin throws errors
    - Working fine. True :D.

    Banner issue Not fixed. Still testing but my initial tests with only selected categories indicates it still does not hold banners to show on only those selected categories.
    EDIT: See photo example 2 posts below.

    Future start issue Cant reproduce. Not fixed, pictures to illustrate below.
    EDIT: Fixed as of SVN 288!

    Email notification issues not tested yet.
    Dutch auction related issues not tested yet.


    Future Start Issue images from testing on default load:
    1. Time of listing shown.
    1.jpg
    2. Start time selecting during initial listing, 3 hours in the future.
    2.jpg
    3. Date shown from sell review page (2nd).
    3.jpg
    4. Click make changes, date now shown on initial (reloaded) sell page.
    4.jpg
    5. Click process, date now shown on sell review page.
    5.jpg
    6. Click process auction, date shown on auction page.
    Not letting me add, see next post. Date and time shown: Nov 06, 2012 - 20:35
     
    Last edited: Dec 12, 2010
  16. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    6th image:
    6.jpg
     
  17. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    Banner Bug follow-up with pictures from Default load

    r. 286

    1. Banner entered with only Toys category and subs selected.
    1.jpg
    2. Banner shows on login page.
    Shows on other pages too but I don't think this has ever been brought up as an issue so not part of the Bug but worth mentioning. If banners are sold then maybe other pages should be optional as well as categories.

    2.jpg
    3. Banner shows in Antiques category (as illustration, shows on all others too).
    3.jpg
     
  18. Southern Holsters

    Southern Holsters New Member

    Joined:
    Oct 31, 2010
    Messages:
    79
    Likes Received:
    8


    Mine must be doing the same as yours. It's transposing the date for me. Using the default date of 12-03-2010, hit submit, it says The start date cannot be in the past and changes the date to 03-12-2010. Hit submit again it takes it, but changes it back to 12/03/2010 on the sell review page. Hit submit and it takes it.

    How do I get pending auctions to show on the home page? Not sure if I disabled it somewhere but can't find where. It is showing as pending on my control panel.
     
  19. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    Thanks for retesting. ;) You mention "it takes it", what date finally makes it to the auction. My results are not simple transpositions. If you get a chance maybe you can note the date/time for each step and/or "change" action.

    This info. may help Renlok nail down what's happening.

    Thanks again. We really need people to do at least these follow-ups (if not full testing!) since Renlok can't code and test all the scenarios. [blue in the face, not holding breath emoticon]



    Thread is for Bug reports only.
    You might want to start a thread outside of the testers forum.

    It's not in place and Pending auctions would need to be a Mod. Since they are pending most users would probably not want them to be shown.

    As an example, Pending can be used to start auctions while someone is away so that they start the day they get back. They don't want them show since they are not available to answer questions. They can also be used to set up a lot of auctions all to start/end the same day/time or close to it (end on a Saturday for example).


    Even as a single seller I'm not exactly sure why you would want to show them.
    :confused:
     
    Last edited: Dec 2, 2010
  20. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    Pictures to show I wasn't crazy (at least about this issue). Guess I could do the same!:

    1. Time of listing shown: 11/30/2010 17:35
    2. Start time selecting during initial listing, 3 hours in the future: 11/30/2010 20:35
    3. Date shown from sell review page (2nd): 06/11/2012
    4. Click make changes, date now shown on initial (reloaded) sell page: 06/11/2012 20:35
    5. Click process, date now shown on sell review page: 11/06/2012
    6. Click process auction, date shown on auction page: 11/06/2012 20:25
     
Thread Status:
Not open for further replies.

Share This Page