Problem With vietnamese Language

Discussion in 'Languages' started by hieu, Oct 30, 2015.

  1. hieu

    hieu New Member

    Joined:
    Oct 30, 2015
    Messages:
    7
    Likes Received:
    0
    [​IMG]
    In my language, i have this error, please help me! i use WeBid 1.1.2P2, my language is vietnamese
     
  2. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    549
    MODERATOR NOTE
    Please do not Hijack other posts that have nothing to do with your question. You posted this in the thread about Spanish not working. Vietnamese is not Spanish so start a new thread.

    I have moved your post to its own new thread and ask you to please
    READ THE RULES
     
  3. hieu

    hieu New Member

    Joined:
    Oct 30, 2015
    Messages:
    7
    Likes Received:
    0
    ok thanks, who can help me please
     
  4. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    I would check the charset of your database, most of the time this is the problem. Im not sure what is best for vietnamese but a quick google would give you the answer
     
  5. hieu

    hieu New Member

    Joined:
    Oct 30, 2015
    Messages:
    7
    Likes Received:
    0
    How can i repair it?
     
  6. hieu

    hieu New Member

    Joined:
    Oct 30, 2015
    Messages:
    7
    Likes Received:
    0
    i don't understand how can i do
     
  7. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    549
    log in to your WeBid database via PhpMyadmin in your web hosting control panel and change the charset/collation of the database to one that works with Vietnamese.
    As renlok pointed out do a Google search to find the right charset/collation to use for Vietnamese.

    About character sets and collation
    MySQL enables you to store and process data in a wide variety of languages using various character sets. For some operations, such as comparing two strings, MySQL uses a set of rules to determine equality and sorting order. This set of rules is known as a collation.

    You may have to change the collation for a database or table based on the character set you want to use for string data. You can do this by using the phpMyAdmin tool in cPanel.

    Changing the default collation for a database
    To change the default collation for a database, follow these steps:

    1. In the Databases section of the cPanel home screen, click phpMyAdmin. The phpMyAdmin administration page appears in a new window.
    2. In the left pane, click the name of the database you want to modify.
    3. On the top menu bar, click Operations.
    4. Under Collation, select the collation that you want for the database, and then click Go.
      This setting only affects new tables that you create. Any existing tables maintain their current collation setting.
    Changing the collation for a table
    To change the collation for a database table, follow these steps:

    1. In the Databases section of the cPanel home screen, click phpMyAdmin. The phpMyAdmin administration page appears in a new window.
    2. In the left pane, click the + icon next to the name of the database that contains the table you want to modify. phpMyAdmin expands the view to show the database's tables.
    3. Click the name of the table you want to modify.
    4. On the top menu bar, click Operations.
    5. Under Table options, in the Collation list box, select the collation that you want for the table, and then click Go.
     
    Last edited: Oct 31, 2015
  8. hieu

    hieu New Member

    Joined:
    Oct 30, 2015
    Messages:
    7
    Likes Received:
    0
    i changed Collation to utf8_general_ci and utf8_unicode_ci but my problem is the same
     
  9. hieu

    hieu New Member

    Joined:
    Oct 30, 2015
    Messages:
    7
    Likes Received:
    0
    I correct my text in database, but my web has the same problem[​IMG] [​IMG]
     
  10. Pattanapong Suwan

    Pattanapong Suwan New Member

    Joined:
    Apr 8, 2016
    Messages:
    5
    Likes Received:
    0
    Do you setting your DB to utf-8-unicode-ci when you create DB?
     
  11. hieu

    hieu New Member

    Joined:
    Oct 30, 2015
    Messages:
    7
    Likes Received:
    0
    I did, but it can't work
     

Share This Page