Picture Problems

Discussion in 'General Support' started by willie147scott, Jun 25, 2009.

  1. willie147scott

    willie147scott New Member

    Joined:
    May 26, 2009
    Messages:
    23
    Likes Received:
    0
    Hi,

    I have found that when I try to upload pictures with any CAPITAL letters in the filename then the image will upload but will not display. Just a white box with a red "x". The same happens if there is a space in the file name? Even in the filename is in lower case but the JPG is in upper case this happens which is a pain cos if extensions for know filetypes are hidden then no one would know this.

    Is this how it should be? Is there a way to stop this cos it is gonna be a nightmare for me to have to continually have to talk people in my work through how to sort things like this.

    I am using the program to raise money for charity via an internal auction with my work colleagues and we are going to open up registration soon but want to sort any bugs out in advance.

    Regards

    Willie
     
    Last edited: Jun 25, 2009
  2. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    Ive not been able to reproduce this but ive made some tweeks to the code and i think it should be fixed now if you could replace your upldgallery.php with the one i uploaded and could you see if that fixes the problem?

    (made a fix to file)
     

    Attached Files:

  3. willie147scott

    willie147scott New Member

    Joined:
    May 26, 2009
    Messages:
    23
    Likes Received:
    0
    Thank you Renlok. Off work today studying for a Microsoft Exam which I have tomorrow so will give it a go when I get back to work after the exam.

    Cheers

    Willie

     
  4. clivester

    clivester New Member

    Joined:
    Dec 14, 2008
    Messages:
    370
    Likes Received:
    2
    I can confirm this.

    I noticed it with extensions in uppercase. Thus myfile.jpg would upload with no problem, but myfile.JPG would not. The symptom would be that no image would appear for thumbnail selection.

    I suspected it was due to validity checking for correct file type not taking into account uppercase extensions, but did not look into it further.
     
  5. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,617
    Likes Received:
    164
    I didn't have an issue with capital letters but did with spaces in name. Renlok's site was fine with spaces so seems like another server specific one.

    Loading this resulted in errors, maybe an added file for upcoming version:
    EDIT: Clive popped in after and I didn't check xx.JPG.
    Back! - I can confirm this one as well, images with CAPS suffix don't show an image.
     
    Last edited: Jun 25, 2009
  6. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,617
    Likes Received:
    164
  7. n_seine

    n_seine New Member

    Joined:
    Dec 4, 2008
    Messages:
    56
    Likes Received:
    1
    Had this problem on 0.7.4 fix worked wonderfully thank you fixed all the problems with thumbnails and picture uploads

    Ken
     
  8. eddie

    eddie New Member

    Joined:
    Feb 14, 2017
    Messages:
    1
    Likes Received:
    0
    I am using V1.2.1 ! Same issue!
    Uploading images for an auction, not working! The images are uploaded to /uploaded/"HASH"/"HASH-NAME.JPG" (CAPS EXTENSION NAME) and are not moved to /uploaded/1/"hash-image-name.jpg" !

    I replaced the original file /upldgallery.php with the one you provided here and I am getting some errors! The gallery upload pop-up is 404 Error showing :
    "
    Internal Server Error
    "

    In the error log: "PHP Fatal error: Call to a member function assign_vars() on a non-object in /upldgallery.php on line 217"

    what's to be done?
     

Share This Page