No user authentication [not working]

Discussion in 'General Support' started by rantnik, Oct 29, 2008.

  1. rantnik

    rantnik New Member

    Joined:
    Oct 29, 2008
    Messages:
    19
    Likes Received:
    0
    In the admin sections: PREFERENCES -> Users Authentication
    I want to change settings and choose "No user authentication", but when I press "Save changes" nothing saves
     
  2. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    ok fixed this aswell

    replace your admin/usersauth.php with
    Code:
    <?php
    /***************************************************************************
     *   copyright				: (C) 2008 WeBid
     *   site					: [url]http://www.webidsupport.com/[/url]
     ***************************************************************************/
    
    /***************************************************************************
     *   This program is free software; you can redistribute it and/or modify
     *   it under the terms of the GNU General Public License as published by
     *   the Free Software Foundation; either version 2 of the License, or
     *   (at your option) any later version. Although none of the code may be
     *   sold. If you have been sold this script, get a refund.
     ***************************************************************************/
    
    require('../includes/config.inc.php');
    include "loggedin.inc.php";
    
    #//
    $ERR = "";
    
    #//
    if($_POST['action'] == "update")
    {
    	$query = "UPDATE ".$DBPrefix."settings SET
    			usersauth='".addslashes($_POST['usersauth'])."'";
    	$res_ = mysql_query($query);
    	if(!$res_)
    	{
    		print "Error: $query
    ".mysql_error();
    		exit;
    	}
    	else
    	{
    		$SETTINGS['usersauth'] = $_POST['usersauth'];
    		$ERR = $MSG_25_0155;
    	}
    }
    
    ?>
    <HTML>
    <HEAD>
    <link rel='stylesheet' type='text/css' href='style.css' />
    </HEAD>
    <body bgcolor="#FFFFFF" text="#000000" link="#0066FF" vlink="#666666" alink="#000066" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
    <table width="100%" border="0" cellpadding="0" cellspacing="0">
      <tr> 
        <td background="images/bac_barint.gif"><table width="100%" border="0" cellspacing="5" cellpadding="0">
            <tr> 
              <td width="30">[img]images/i_gra.gif[/img]</td>
              <td class=white><?=$MSG_25_0008?>&gt;&gt;<?=$MSG_25_0151?></td>
            </tr>
          </table></td>
      </tr>
      <tr>
        <td align="center" valign="middle"></td>
      </tr>
        <tr> 
        <td align="center" valign="middle">
    <TABLE BORDER=0 WIDTH=100% CELLPADDING=0 CELLSPACING=0 BGCOLOR="#FFFFFF">
    <TR>
    <TD align="center">
    
    
    <FORM name="conf" ACTION="" METHOD="POST">
    	<TABLE WIDTH="95%" BORDER="0" CELLSPACING="0" CELLPADDING="1" BGCOLOR="#0083D7">
    		<TR>
    			<TD ALIGN=CENTER class=title>
    				<?php print $MSG_25_0151; ?>
    				</TD>
    		</TR>
    		<TR>
    	<TD>
    		<TABLE WIDTH=100% CELLPADDING=4 ALIGN="CENTER" BGCOLOR="#FFFFFF">
    		  <?php
    		  if($ERR != "")
    		  {
    		?>
    		  <TR>
    			<TD COLSPAN="2" ALIGN=CENTER bgcolor="yellow">[B]
    			  <?php print $ERR; ?>
    			  [/B]</TD>
    		  </TR>
    		  <?php
    		  }
    		?>
    		  <tr valign="TOP">
    			<td colspan="2">[img]../images/transparent.gif[/img]</td>
    		  </tr>
    
    		  <tr valign="TOP">
    			<td width="100%"> 
    			  <?php print $MSG_25_0152; ?>
    			  
    
    
    			  <input type="radio" name="usersauth" value="y"
    					 <?php if($SETTINGS['usersauth'] == 'y') print " CHECKED";?>
    					 >
    			  
    			  <?php print $MSG_25_0153; ?>
    			  
    			  
    
    			  <input type="radio" name="usersauth" value="n"
    					 <?php if($SETTINGS['usersauth'] == 'n') print " CHECKED";?>
    					 >
    			  
    			  <?php print $MSG_25_0154; ?>
    			   </td>
    		  </tr>
    		  <TR>
    			<TD WIDTH="100%">
    			
    
    			  <INPUT TYPE="hidden" NAME="action" VALUE="update">
    			  <INPUT TYPE="submit" NAME="act" VALUE="<?php print $MSG_530; ?>">
    			</TD>
    		  </TR>
    		  <TR>
    			<TD WIDTH="100%"> </TD>
    		  </TR>
    		</TABLE>
    	</TD>
    	</TR>
    	</TABLE>
    	</FORM>
    </TD>
    </TR>
    </TABLE>
    </TD>
    </TR>
    </TABLE>
    </BODY>
    </HTML>
    
     
  3. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    also thanks for posting the bugs you find :) its really helpful.
     
  4. rantnik

    rantnik New Member

    Joined:
    Oct 29, 2008
    Messages:
    19
    Likes Received:
    0
    Thanks, now everything is OK :)
     

Share This Page