Item Report maybe could use some improvment

Discussion in 'Requests' started by david62311, Dec 1, 2016.

  1. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,144
    Likes Received:
    246
    Let's chat about the item report function. I was looking at my own item and saw the link called item report and clicked on it and filed a report that the item was stolen. My admin didn't get a message or email about it. I think the admin should get a message alert. I checked Github and noticed it reports the report in the admin/listreportedauctions.php so, I checked there to see what was there. I found I could navigate there in the admin panel under Auctions>View Reported Auctions. It shows the item I reported but, there is no description that I can see of what's been reported. If I just look at the auction list in the admin panel it shows the report item text in orange but, still no message of what the report is.

    • Shouldn't the admin get an email when an item is reported?
    • Shouldn't there be a message showing in the admin panel to get the admin's attention?
    I think the item report could use some improvements. Does anybody have any opinions about this?
     
  2. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    From what you said above I agree although I have not tested this, What version we talking about
     
  3. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,144
    Likes Received:
    246
    That is a really good question. So much confusion when all of the updates happened. I got this I think last September. This is what it says in my admin panel.
    WeBid Version 1.2.1 (1.2.1)

    This was the last known working version that I knew of before Renlok said the script from Github had been updated and it needed fixes. That was when I stopped telling people to go to Github and use the update from there. I have no idea if the script from Github has been improved enough to use or what version we are on now.

    Here's a list of what I found in the Webid Github site. https://github.com/renlok/WeBid/search?utf8=✓&q=reportedauctions
     
    Last edited: Dec 1, 2016
  4. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,144
    Likes Received:
    246
    In the photo I painted over the username and part of the item description but, that is all that it shows in the View Reported Auctions

    capture-20161201-015426.png

    The actual database table for this looks like this:

    capture-20161201-020316.png

    It's showing what the reason there in the database which is #5. I don't see a text area there for the message but, maybe there isn't supposed to be one there.
     
    Last edited by a moderator: Dec 2, 2016
  5. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,144
    Likes Received:
    246
    Of course now I see there have been pages added since my install. Good call @nay27uk to get me looking at the Github a bit closer before I got into this. Time saved not wasting time is always nice! :) I found that I am missing the /themes/adminClassic/listreportedauctions.tpl file. I just added it. I am thinking now that my database webid_reportedauctions table will probably have to be rebuilt too. I say that because there is no message there and just an array number of 5 there.

    I think I better run a fresh install on a back page in case things in the latest Webid Github Script are screwy. I could probably just run an fresh update to a July version that I have on a back page to test that the updater is still working too while I am at it.

    Great now my site is down. It's a new month. I would say my server people gave me an ssl certificate that expired. Now I have to wait for them to fix my site. My time saved now is wasted on this now. :(

    Here's the error I get:
    This site can’t be reached
    The webpage at https://....com might be temporarily down or it may have moved permanently to a new web address.

    ERR_SSL_UNRECOGNIZED_NAME_ALERT
     
  6. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    Ha ha if it's not one thing its another LOL.
    The reason I asked is I do have 1.2.1 installed but never noticed that section in the admin as I have not really gone through everything as yet
     
  7. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,144
    Likes Received:
    246
    They pushed a button and fixed my ssl problem. Apparently it had automatically reinstalled today a couple of hours before I wrote that. Their automatic update may be to blame. It's fixed now so, no biggie.

    I downloaded the latest Webid Script from Webid and the The Webid Update is fried. :eek: My backpage Webid site is now trashed completely...but, I have good news. I backed it up. It won't let me access anything. All I get is.

    mysite.com is currently unable to handle this request.

    500

    That's going to be too hard to troubleshoot with no access aloud to it. I hope all the work timw did to get that updater and everything else that had Webid working properly is not lost.

    I extracted my prior zip file and loaded all of my old files back up and now it connects.
     
    Last edited: Dec 1, 2016
  8. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    Hmm changing the subject a bit here but still on topic of the last post and on the subject of timw has anyone else noticed that these guys keep coming here virtually rewriting the whole of webid then just disappear never to be seen again.

    First there was that other arrogant member that I had altercations with that virtually rewrote the whole of WeBid and frankly left it in a right state (you know the one that brought us Classic and Modern themes amongst other things AWWWW) and then he disappeared never to be seen again, now timw virtually rewrote all of the other guys work and bad coding and got webid to where it is now almost fully working bar a few little bugs but now he seems to have vanished to.

    Something to me just doesn't add up and I smell a rat. it is a shame because I really liked TIM I held the guy in high respect.

    I am making no implications here but it seems very strainge to me how they just disappear after doing all that hard work never to post to the forums or github again, although I have not checked git hub for a long time now so I could be wrong they may still be working behind the scenes.
     
    Last edited: Dec 2, 2016
  9. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    OK I do have 1.2.1 installed so will go do some testing on this one
     
  10. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,144
    Likes Received:
    246
    Timw removed the Countries array file we had and created a table for in the database in it's place called the webid_countries table. I am using to show an example that it uses id numbers but, it also has some text there under the country column.

    Countries.png

    This is what the webid_reportedauctions table looks like and it has no message there. I think there could be a message column put there.

    reported auction.png

    If there have been updates done on this to change the table on Github on a new install or update then I have no idea if there was. I can't get the Report Item to work just by using the updated codes from Github on the pages that would require the updates. It gives me a 500 internal error. What I am getting at is there have been changes there but, I don't know what they are without seeing them work on my site. I will have to do some exploring to see what's been updated.
     
  11. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    OK one major problem I have found with this is that if you get the captcha wrong and click submit the page refreshes to show the error but the dropdown box is also cleared of your choice. I thought I keept getting the captcha wrong about 8 times but after the first time I got it wrong the rest where because the dropdown had lost its selection.

    This needs to be fixed so that the selection is remembered if there is any error, either that or don't refresh the page to show an error
     
  12. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    Hmmm this whole report a listing thing don't seem very well thought out to me.

    First off the only actions the admin can take are EDIT, DELETE and SUSPEND where is an option if the item is reported for ACCEPT LISTING not all reports will always be in breach of what it is being reported for.

    On all of the auction pages in admin, in the table on each of the pages the table header says the same thing no matter what tab you're on they always say ITEM TITLE this should change by the page according to the auction page the admin is looking at, so if he is looking at the View Open Auctions tab for example then in the table where it says ITEM TITLE it should say ACTIVE ITEM TITLE if looking at the View Closed Auctions tab then ITEM TITLE should be CLOSED ITEM TITLE For the View Reported Auctions tab it should be REPORTED ITEM TITLE etc etc this just causes confusion with it being ITEM TITLE on every tab. Each tab under Auctions should use its own separate TPL file instead of all using listauctions.tpl that is the way to have them all with different table headers.

    The user Reporting the Auction should get a confirmation email saying thanks for reporting this auction for XX reason one of our staff members will look into this in the next 48 hours.

    The admin should also have the option under the ACTIONS to email the reporter after he has checked the Reported Auction to let them know the outcome of the Reporting.

    The user who posted the auction should get an email telling them that their auction has been reported for xxx reason and that a team member is looking into this, that the auction will still be active during this time but if found to be in breach of any terms etc then will either be suspended or removed.

    That's all I can see wrong at the moment but thats bad enough I dont think this was thought out properly
     
    Last edited: Dec 3, 2016
  13. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    Thinks I am going to play around with the admin Auctions Pages because they are still a mess and should have different table headers for each page clicked on even if this meens me making 3 or 4 new tpl files then so be it.
     
  14. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    I Don't get these pages at all.

    How is a SUSPENDED AUCTION an OPEN AUCTION? NO it's not, it is closed for view (suspended) so is not an OPEN AUCTION so why does it get listed under OPEN AUCTIONS thats just WRONG
     
  15. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    David you have opened a big can of worms here mate.

    Now you have got me ripping the whole AUCTIONS tab and all of its child tabs to bits mate because frankly they all suck.

    How they all are now, every one of them is just totally wrong in my eyes.
     
  16. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    OK here is what I am working on for the auctions tab of the admin side like I said above they are all messed up.

    This is an image of the open auctions page and for some reason they include both Reported Auctions and Suspended Auctions and that as WeBid is now are just a silly change in font colour with no explanation of what is what (like david pointed out above) so here is my new and improved Open Auctions Page if the Open Auctions page must have both Reported Auctions and Suspended Auctions listed where they should not be.

    image 1.jpg

    I have also made a new tpl file for the Reported Auctions and I will do the same with all of the other tabs.

    Here is a picture of the new listreportedauctions.tpl notice that each of the headers in the table are named so that we know exactly what page we are on, I will do this for the rest of the pages under the admin Auctions tab (how it should have been in the first place.

    image 2.jpg
     
    Last edited: Dec 3, 2016
    david62311 likes this.
  17. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    I notice there is no way of marking a REPORTED item as UNREPORTED in the actions panel, so how exactly do we make a REPORTED ITEM no longer a REPORTED ITEM?

    I have checked all, of the admin as well as in the item page and it is not there either.

    If the admin can't change it to "UNREPORTED" or click a link that says "MARK AS UNREPORTED" then it is always going to show up in the admin panel and in the stupid Orange Text as "REPORTED".

    Someone never thought this over did they?
     
    Last edited: Dec 3, 2016
  18. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,144
    Likes Received:
    246
    Sorry, I had to step out for the day. Wow! You've been busy @nay27uk .

    The answer to #15 is yes, I may have opened a can of worms there.

    It's going to take me a while to read through all of your messages here. I will try to read everything and reply sometime tomorrow.
     
  19. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,144
    Likes Received:
    246
    I read through some more but, still have a lot to absorb. I like the Status Column you added nay27uk. Good job!

    I was wondering does adding a place for admin messages sound like a good idea like for example how when the user signs in the user will see a message in the user_menu.php page if there is one? Part of the code for it is right here: https://github.com/renlok/WeBid/blob/cf9e323c5d8a46bb827d8feac8188c3461f93901/user_menu.php#L133

    I am thinking because there might be other places where messages should get reported that the admin should receive something similar to what I mentioned above. It might be easier to add an envelope icon at the top right of the admin panel that alerts us when we get a message like we have in this forum. Oh, even like the forum has, adding a pop up message might be nice too.

    I got to hit the sack. I am tired and I got a long day ahead. I will come back and look at what's been posted here later.
     
  20. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    546
    Yeah sounds good to me having a reminders like the regular users do would be good.
    Need to get those auctions pages sorted first though and this reported auctions fixed because an admin can never mark the item as unreported so it will remain reported till it closes
     

Share This Page