Item Condition Mod 2015-04-23

Displays Item Condition, Manufacturer, Model,Colour,Year of Manufacture on item page

  1. drakky20

    drakky20 Active Member

    Joined:
    Mar 11, 2012
    Messages:
    253
    Likes Received:
    24
    drakky20 submitted a new resource:

    Item Condition Mod - Item Condition Mod

    Read more about this resource...
     
    Last edited by a moderator: May 23, 2016
  2. Xeonn

    Xeonn New Member

    Joined:
    Dec 15, 2011
    Messages:
    371
    Likes Received:
    55
    IMO , for quick look at install instruction, you forgot to add conditions how to add to view in admin section or where to link it in admin section
     
  3. drakky20

    drakky20 Active Member

    Joined:
    Mar 11, 2012
    Messages:
    253
    Likes Received:
    24
    yes sorry i realised that after i had sent the file but being under moderation i couldn't edit it or make a comment here's the code

    #-----[ OPEN themes/admin/sidebar-settings.tpl -------------------

    #find

    # <li><a href="{SITEURL}admin/errorhandling.php">{L_409}</a></li>

    # add after

    <li><a href="{SITEURL}admin/conditions.php">{L_1041}</a></li>


    ##------------------------------------------------------------
    #-----[ SAVE/CLOSE themes/admin/sidebar-settings.tpl]--------------------------
    ##----------------------------------------------------------------

    and here's the whole zip with the correction in it (just incase anyone misses this correction)
     

    Attached Files:

    Last edited: May 7, 2012
    Xeonn likes this.
  4. j2000

    j2000 New Member

    Joined:
    Apr 29, 2012
    Messages:
    38
    Likes Received:
    0
    Hi all , i got an error..
    Item Condition Error on sell.php , message is :
    Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /sell.php on line 517

    I dont know how to correct it , before i edit sell.php for "item condition" , yesterday i've edit sell.php for "item and seller location" successfull...


    Regards

    Joel
     

    Attached Files:

  5. j2000

    j2000 New Member

    Joined:
    Apr 29, 2012
    Messages:
    38
    Likes Received:
    0
    I try to correct , this is right ?
     
  6. Xeonn

    Xeonn New Member

    Joined:
    Dec 15, 2011
    Messages:
    371
    Likes Received:
    55
    View attachment sell.php.aftermod.item.cond.zip
    Hi , I just fix your sell.php
    you forgot to add "," coma sign in line 514.
    Attachment is fixed, I hope I helped you with it :)

    this what you wrote is OK, you must remember that in code template vars array only the last position is ended without coma.
     
    Last edited: May 6, 2012
    j2000 likes this.
  7. j2000

    j2000 New Member

    Joined:
    Apr 29, 2012
    Messages:
    38
    Likes Received:
    0
    owwwgh...thanks very much Xeonn...
    I gain new knowledge... :)
     
  8. j2000

    j2000 New Member

    Joined:
    Apr 29, 2012
    Messages:
    38
    Likes Received:
    0
    Last edited: May 6, 2012
  9. drakky20

    drakky20 Active Member

    Joined:
    Mar 11, 2012
    Messages:
    253
    Likes Received:
    24
    sorry must have missed that edit too , it's not sql make sure you have all the lines in here

    PHP:
    #-----[ OPEN language/EN/messages.inc.php]----------------------------------------

    ## find 

    ## $MSG['30_0214'] = "WeBid Version";

    ## after add
    $MSG['1036'] = "Item Condition";
    $MSG['1037'] = "Manufacturer";
    $MSG['1038'] = "Model";
    $MSG['1039'] = "Colour";
    $MSG['1040'] = "Year of Manufacture";
    $MSG['1041'] = "Conditions Table";
    $MSG['1042'] = "Edit, delete or add Item Condition using the form below.";
    $MSG['1043'] = "Conditions Table Updated !";
    $MSG['OPENBUBBLE']='&nbsp;&nbsp;&nbsp;<a href="#" class="tt"><img src="themes/default/bubble/info_button_s.png" height="18" width="18" align="top" border="0"><span class="tooltip"><span class="top"></span><span class="middle">';
    $MSG['CLOSEBUBBLE']='</span><span class="bottom"></span></span></a>';
    $MSG['REQUIRED']='<font color="red"><b>* Means required information</b></font>';
    $MSG['ASTERIX']='<font color="red">*&nbsp;&nbsp;</font>';
    $MSG['1044'] ="What does each Item Condition mean?";
    $MSG['1045']="This will be the title of your listing. Use words about your item that buyers would search for.";
    $MSG['1046']="display more information below your title, make your listing more interesting";
    $MSG['1047']="Make sure you choose the right condition it's important to accurately describe your item";
    $MSG['1048']="describe your item in Detail";
    $MSG['1049']="Upload images for your listing -automatic thumbnail made here too, you can make your listing stand out by catching the buyer's eye";

    #-----[ SAVE/CLOSE language/EN/messages.inc.php]----------


    that will fix it, I have updated the downloads to include the missing lines
     
    Last edited: May 7, 2012
    j2000 likes this.
  10. j2000

    j2000 New Member

    Joined:
    Apr 29, 2012
    Messages:
    38
    Likes Received:
    0
    Its work Drakky , thanks :)
     
  11. drakky20

    drakky20 Active Member

    Joined:
    Mar 11, 2012
    Messages:
    253
    Likes Received:
    24
    no problem you're welcome j2000
     
  12. ffxpwns

    ffxpwns New Member

    Joined:
    Apr 15, 2012
    Messages:
    55
    Likes Received:
    4
    Friendly tip; The current mysql code didn't work with my database. Mine uses semicolons as a delimiter. I don't know if thats normal, but all I had to do was change


    PHP:
    ALTER TABLE `webid_auctionsADD `item_conditionvarchar(40) default '',
    ALTER TABLE `webid_auctionsADD `item_manufacturervarchar(32) default '',
    ALTER TABLE `webid_auctionsADD  `item_modelvarchar(32) default '',
    ALTER TABLE `webid_auctionsADD  `item_colourvarchar(32) default '',
    ALTER TABLE `webid_auctionsADD  `item_yearvarchar(11) default '',
    To

    PHP:
    ALTER TABLE `webid_auctionsADD `item_conditionvarchar(40) default '';
    ALTER TABLE `webid_auctionsADD `item_manufacturervarchar(32) default '';
    ALTER TABLE `webid_auctionsADD  `item_modelvarchar(32) default '';
    ALTER TABLE `webid_auctionsADD  `item_colourvarchar(32) default '';
    ALTER TABLE `webid_auctionsADD  `item_yearvarchar(11) default '';
     
  13. tholyoak

    tholyoak New Member

    Joined:
    Apr 11, 2011
    Messages:
    23
    Likes Received:
    2
    Typically you would combine all operations in a single table into one statement, which would use the commas between column names (and only name the table once). Semicolons are normally used at the end of each statement, so if you're doing each operation separately, that is the correct way to do it.
     
  14. drakky20

    drakky20 Active Member

    Joined:
    Mar 11, 2012
    Messages:
    253
    Likes Received:
    24
    please feel free to post it as it should be , i just used what worked for me on my server , I'm no coder
     
  15. liran

    liran New Member

    Joined:
    May 17, 2012
    Messages:
    136
    Likes Received:
    2
    works perfect

    good job on this one :p
    works perfectly good!! thanks!
     
  16. Rupert Avery

    Rupert Avery New Member

    Joined:
    Nov 24, 2011
    Messages:
    157
    Likes Received:
    4
    Is it possible to edit the default conditions and mods completely?
     
  17. drakky20

    drakky20 Active Member

    Joined:
    Mar 11, 2012
    Messages:
    253
    Likes Received:
    24
    default conditions are settable in the admin panel -->settings tab--> conditions table on left
    you set the choice and its meaning in there
     
    Rupert Avery likes this.
  18. Rupert Avery

    Rupert Avery New Member

    Joined:
    Nov 24, 2011
    Messages:
    157
    Likes Received:
    4
    I am going to try in stall it later today hopefully I can get this to work :) thank you
     
  19. Rupert Avery

    Rupert Avery New Member

    Joined:
    Nov 24, 2011
    Messages:
    157
    Likes Received:
    4
    Is it possible to add these conditions to just 1 category or dies it automatically go to all categories?
     
  20. liran

    liran New Member

    Joined:
    May 17, 2012
    Messages:
    136
    Likes Received:
    2
    hey drakky , thanks for this mod=)
    after setting this mod , i've tried editing existing items, and it wont let me.
    says its a problem in the sql database.

    i've uploaded a picture of my database as creating the webid conditions, and after.

    can you tell me whats wrong please?

    http://img507.imageshack.us/img507/5479/helpy.jpg
     

Share This Page