Is 1.0.0 Testing done? How about a rally Testers?

Discussion in 'Testers' started by Box Lot, Aug 17, 2010.

  1. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    It's been a few full weeks since new testing issues have been posted by others.

    Possibly that is a sign that 1.0.0 is ready for Renlok to tackle the already posted bugs :)D!) and it would be great to put the 1st of the 1.x breakdowns to bed.

    I hope that is the case but if you haven't already put things through their paces this would be a good time to do it so that Renlok has all current realized bugs in front of him.

    Once done, and after what should be relatively quick re-testing of already reported bugs only, then hopefully Renlok can be confident in a 1.0.0 public release and can move on to 1.1.0 which includes a number of game changing additions. Many of these additions I personally feel are nearly a requirement of a functional public WeBid site. Most certainly true with regards to the administration and publication of the site (Google!).

    With added and step up dedication to the project we can get to a stage (post 1.1.0) that will allow for much more freedom and creativity both in terms of function and design.

    If you think Renlok has shined so far (which of course he has in Spades :cool:) I think the post 1.1.0 work will be his best yet since he will finally have the freedom and time to step back and take a good look at the project and what HE wants it to be. That freedom will translate to us as well and I'm hopeful will produce suggestions and additions that will leave the already bested comparison packages and sites in the dust.



    FYI, you most certainly don't have to be an original or long term tester to jump in here and anyone can post their bugs here. The more eyes and different browsing methods the better, everyone tests differently and/or has different focus.

    Basic testing is really just a matter of browsing your site as any user would in normal day to day operations. Setting up two users for bid and auction testing is a welcome bonus.

    Don't be afraid to post things your not sure are truly bugs, that is the idea and your posted concern will be addressed regardless.

    Also, to be clear. Post bugs in the Mega Testing Thread and not here.
     
    Last edited: Aug 18, 2010
  2. Daronna

    Daronna New Member

    Joined:
    May 3, 2010
    Messages:
    12
    Likes Received:
    0
    Hi Other Testers;

    1. Is SMTP mail option going to be incorporated in the new version? This seems to be a big issue with (we) Window users.

    2. Admin Categories in v.1 that I downloaded yesterday, seem to extend far to the right on my 19inch monitor, using the latest IE.

    Thank you Daronna
     
  3. Daronna

    Daronna New Member

    Joined:
    May 3, 2010
    Messages:
    12
    Likes Received:
    0
    I'm not sure if this is an issue or may become an issue, but looking through the db with phpMyAdmin; there are several tables without a defined index:

    Below you will find the tables with their columns. If you think this might be an issue at any time, kindly let me know which column SHOULD be defined and I will fix it on my end.

    If it is a non-issue, can you also let me know that, because if I should stumble across a hiccup, I will always wonder if its the undefined index.

    Thank you ever so much in advance
    Daronna

    webid_bannerscategories
    banner
    category

    webid_bannerskeywords
    banner
    keyword

    webid_closedrelisted
    auction
    relistdate
    newauction

    webid_news_translated
    id
    lang
    title
    content

    webid_proxybid
    itemid
    userid
    bid

    webid_rememberme
    userid
    hashkey
     
  4. Daronna

    Daronna New Member

    Joined:
    May 3, 2010
    Messages:
    12
    Likes Received:
    0
    In Manage FAQs, when you adjust a FAQ, it doesn't hold the category.

    When I made a change to a FAQ I had in the Selling category, the drop down defaulted to Buying.
    You have to be careful and re-select the category you want the topic in.

    Hope this makes sense
    Daronna
     
  5. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    1. Renlok has noted that he is planning on adding an SMTP option but not when it will be implemented. Possibly 1.1.0 but I would imagine not 1.0.0.
    (http://www.webidsupport.com/forums/showthread.php?858-Specifying-SMTP-server&highlight=smtp)

    2. You can scroll to the right though right? You could adjust this if you like in your theme. /themes/YOUR THEME/admin/
    I think this is default to allow for long titles and the like and wouldn't call it a bug myself.

    Thanks for jumping in! :D
     
  6. Daronna

    Daronna New Member

    Joined:
    May 3, 2010
    Messages:
    12
    Likes Received:
    0
    News Management

    Hi All

    In v.1 Admin> Contents> News Management; when clicking on add, nothing appears except the top navigation. The rest of the page is blank.

    There doesn't seem to be a place to add News. Using both IE and FireFox

    Thank you
    Daronna

    BTW - Yes with regards to Admin Categories which I wrote about below, I can scroll to the right, so this becomes a non-issue.
     
    Last edited: Aug 18, 2010
  7. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    I cannot replicate this with Firefox.

    So you get to the page that has "News Management" and "Add new" below it?

    Check your logs (/logs), do you get any error messages?
     
  8. Daronna

    Daronna New Member

    Joined:
    May 3, 2010
    Messages:
    12
    Likes Received:
    0
    Hi Box Lot

    Yes, I get this when I click Add new in Admin> Contents> News Management

    There is an error regarding this, (I have XXX'd my address as its not ready for prime time) :)

    18-08-2010, 12:04:18:: <b>My ERROR</b> [256] template->_tpl_load_file(): File D:\inetpub\XXXXX\XXXXX\themes/admin/sidebar-content.tpl does not exist or is empty
    Fatal error on line 65 in file D:\Inetpub\XXXXX\XXXXX\includes\functions_template.php, PHP 5.2.13 (WINNT)
    Aborting...

    I never looked at this file before, I have about 480 entries on this error log page since yesterday. Is this normal?

    Thank you Daronna
     
  9. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    Mmm.

    You list a files as .../themes/admin/sidebar-content.tpl
    but there is no theme name. Should really be something like ../themes/default/sidebar-content.tpl

    Also in the default package there is no admin/sidebar-contents.tpl files. Are you using a contributed theme or some Admin Mod?

    The second error notes that it couldn't open the template file because it doesn't exist.

    If you using a custom theme then make sure you've uploaded all of the included files and particularly of course look for this one. Failing that and if the theme is supported by the author then you should probably contact them in their theme thread.

    It is not normal nor desired to have that many errors in your log. Ideally you should have none but that is often hard to do (particularly with customizations you might do for various reasons) but you should start chipping away at them prior to launching your site online.


    Ooops, Bugs should be reported in the Mega test thread
    My bad, didn't even realize as I was responding! Duh. Changed the original posting to clarify this further.


    We can continue here with this one Daronna as I don't think it is truly a bug.If/when it becomes clear that it is it can be added as a new entry in the test thread.
     
    Last edited: Aug 18, 2010
  10. Daronna

    Daronna New Member

    Joined:
    May 3, 2010
    Messages:
    12
    Likes Received:
    0
    Hi Box Lot

    I have made no changes at all to this download. This is exactly the files I got using Tortoise SVN.
    As I said I have no mods, nor have I made any changes to the files.

    This is why I have been contributing the bugs I have found as per your invite.

    OH WELL, so much for trying to help with testing.

    I guess you didn't mean "Don't be afraid to post things your not sure are truly bugs, that is the idea and your posted concern will be addressed regardless."

    Daronna
     
  11. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    Wait!

    You've taken this completely wrong. I simply didn't originally make it clear where Bugs should be posted.

    I am addressing your concerns and I just further noted that this one is not a bug so we should continue here that's it.

    The last note just says if we get down the road and it turns out to be a bug we will add an entry to the mega test thread.
     
    Last edited: Aug 19, 2010
  12. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    Ok I see the issue.

    Renlok is currently redesigning the Admin section (theme too but not sure that is in there yet).

    It looks like timing may have put you in a non-functioning state since 2 days ago it appears he started the move of the admin folder with the r.268 release. Prior to that the folder was in the theme folder and that file didn't exist.

    Been a while for one since he was away so I was unaware as my nearly daily checks lapsed while he was gone.

    Hopefully he will stop by and advise where it's at.
     
  13. Daronna

    Daronna New Member

    Joined:
    May 3, 2010
    Messages:
    12
    Likes Received:
    0
    Okay thank you, I will keep looking for new files, and I will keep troubleshooting, if you like.

    This is a fabulous program, and I hope to be able to use it soon.

    This is the only place other than the general forums I can post, as I dont have sufficient permissions, so I was happy to have your invite, and take advantage of your knowledge :)

    Daronna
     
  14. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    Thanks, glad I got it back on track. :D

    I most certainly meant it and there truly are no bad reports and those that aren't true bugs will come out in the wash. It's a part of the process.

    I would ask that you re-post #3 & #4 here into the noted thread for consistency and to make sure all the reports are in one place. Just because I couldn't replicate one of them does not necessarily rule it out as a bug and posting the test thread gives the other participating testers a chance to see if they have the same thing happen.

    If that doesn't happen (not a bug) then you/anyone can start to deal with a problem individual to their installation.

    It wont be a duplication per. se. and you can blame me if anyone yells! :eek:
     
  15. Box Lot

    Box Lot Super Moderator Staff Member Developer

    Joined:
    Dec 18, 2008
    Messages:
    2,623
    Likes Received:
    167
    Well most certainly your welcome.

    If your all signed up and have been approved then there must be an issue here on the board since you should be able to post everywhere. Give Renlok a tick or two and he'll fix it.

    It's happened to me 2 or 3 times during changes here.
     

Share This Page