how to stop my site copy causing havoc!

Discussion in 'Install/Upgrade Support' started by monkey, Jun 5, 2014.

  1. monkey

    monkey New Member

    Joined:
    Mar 13, 2014
    Messages:
    9
    Likes Received:
    1
    My domains are hosted. under one company. I have a site called for example webid.com everything appears to work ok, so then I copied everything to my 2nd site called webid.info and also to webid.co -- I wanted everything the same except the headers, footers and categories. Should be easy - changed the config.php's to suit the new mysql's - but eveytime I look or update something on one site the others revert back to the original .com site - I mean the headers, footers, admin header copywrite dates. Can anyone tell me how I stop this happening - all my work has been repetative for the last 3 weeks - at one stage even the categories from .co site ended up in .com site mixed with the original categories. :mad:

    some help would be very much appreciated thanks - before anyone asks - Yes I changed the http, url in mysql to suit the domains -- could it be that all the domains start with the word for example - webid -- I cannot change my domain names.
     
  2. Guest

    Guest Guest

    why not just install webid on one domain and make redirect to it for the other ?
     
  3. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    547
    First of all I am moving this post to the correct forum its more of a installation problem than a general php topic so I am moving this to the Installation and Upgrade support forum.

    Now on to your question.

    It sounds to me like a path problem in each config.inc.php

    Check and double check that you have the paths right for all your sites in the config.inc.php files this path has to be the exact path to your domain from the server side.

    To find out search the forum for path.zip I uploaded a php script that will display the path for you in the browser, download the path.zip to your computer and unpack it then upload the file inside to your other two in the same place you installed WeBid to on them, run it from the browser and whatever is displayed is what needs to be put in your config.inc.php
     
    Last edited: Jun 5, 2014
  4. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    547
    Seems the zip has diapered from the forum so here it is again.
     

    Attached Files:

    • path.zip
      File size:
      224 bytes
      Views:
      8
  5. Shoe123

    Shoe123 New Member

    Joined:
    Nov 19, 2014
    Messages:
    1
    Likes Received:
    0
    I look or update something on one site the others revert back to the original .com site -
     
  6. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,145
    Likes Received:
    247
    First off, sorry to hear you are using this script on more than one site. It's hard enough to keep up with fixing it to work properly on one site as it is.

    I will assume you cleared the cache in the admin panel to clear out the optimized stuff. What are you trying to do here when you said this?
    What is not changing?
     
  7. athera

    athera Active Member

    Joined:
    Jul 10, 2014
    Messages:
    282
    Likes Received:
    40
    Actually david I think he needs to turn cache off completely
     
  8. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,572
    Likes Received:
    547
    I had this problem when making a theme I had two instances of webid open in the same browser.
    Doing somthing on one reverted me back to the other.
    The answer is a simple one, cookis, you cant have two or more webid installs open at the same time in the same browser.
    Clear your browser cach befor opening your second install or use a different browser for each
     

Share This Page