1.2 rc5

Discussion in 'Testers' started by renlok, Sep 3, 2014.

  1. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Right this is just a small Layout thing.

    On the register page everything is centered on the page apart from the captcha which is aligned to the left.

    Nothing major but it just makes the page look a bit silly.

    Nice new captcha by the way.

    register.jpg

    I will also have to install git on the computer again as I think the layout of the whole register page could do with being split a bit (just simple edits like making the Payment Details heading the same as its above New User Registration heading and adding a few more headings for things like Anti Spam and User Agreement ect) so I can work on some default theme edits some witch may also need to go into the new themes that are in the git version too so I can do those edits then submit them to the git.

    If you want I can also rename my Default Curve themes to Classic Curve as the old Default theme is now called Classic then make the changes to them needed for the git version and submit those to the git that way people downloading WeBid will have 9 or 10 front end themes out of the box 1 Responsive and 7 or 8 non responsive.
     
    Last edited: Mar 28, 2016
  2. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    OK installing the GIT version on the local PC in xampp when visiting the admin page for the first time to input my new admin pass and user after deleting the Install Directory at the top of the page I get this
    admin error.jpg

    OK now I used to have a few errors at the top of the sell page, I can't remember what they said exactly but I do recall they were something very similar and they were both present before you posted the fix for this thread HERE after doing the fix in the above linked thread the errors at the top of the sell page have gone away.

    So I was wondering if this admin page also needs some new code adding into it, code something like the linked to thread above to get rid off these 2 errors on the admin page after a fresh install.

    It just seems funny how the fix in that thread I linked to added some PHP code and the errors disappeared.

    This one seems to be something to do with a Secure Server I.E HTTPS
    functions_global.php lines 67 - 72
    PHP:
            // check if url needs https
            
    if ($system->SETTINGS['https'] == 'y')
            {
                
    $system->SETTINGS['siteurl'] = (!empty($system->SETTINGS['https_url'])) ? $system->SETTINGS['https_url'] : str_replace('http://''https://'$system->SETTINGS['siteurl']);
            }
        }

    After only just installing WeBid my system settings should be set to NO or "N" for the above
     
    Last edited: Mar 28, 2016
  3. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    I did join up with another account Renlok but wont get a chance to do further testing until tomorrow mate
     
  4. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    OK.
    On the item page I am the current Highest bidder and this is correct because I am the current Highest Bidder however when going to the user CP and clicking on Buying and then on Your Bids it says that I am outbid even though I am not and I am 100% sure about that because I never outbid myself with another test account.

    highbid.jpg

    outbid.jpg

    Also in the table above where you see the yellow outbid background the column named "Your Highest Bid" is confusing as there are two prices in it, I am presuming the first one of those is the "Current Bid" and the second one is my "Maximum Bid" If that is not what the two prices are then I am stumped what they are for, they need explaining to the end user what price is what.

    Looking at that again It looks to me like the row "Your Highest Bid" should just say "2,500.00GBP" but it looks like a stray "Current Bid" from the "Current Bid" row next to it has made its way into the "Your Highest Bid" row
     
    Last edited: Apr 7, 2016
  5. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Another thing.

    When viewing your messages from users asking about your item the item title is cut short or cut off if you like.

    messages.jpg

    The above title should read "Test Auction for Later"
     
  6. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    I bet you love me but I am thoroughly testing it for ya.

    Next thing is.

    When viewing your active auctions from the user CP I notice that if there are bids on an auction only the Edit Icon is unavailable but the Edit Column is still visible, I think this could be confusing to a lot of people and I think that if an auction has bids then it should completely hide the whole Edit Row and not just the Edit Icon.

    Should be easy enough by moving the IF in the .tpl around a little bit or if it would not work with moving the IF and maybe adding an ELSE then at least a message in that row something like "Items with Bids cannot be edited" or "Edit Unavailable, Item Has Bids".

    The same as above applies to the "Delete" Row


    edit.jpg

    While we are still on that page the Relisted / Relists row if no relists have taken place should (for the purpose of aesthetics) display a "0" instead of 2 little lines "--"

    The "Started Date" and "Ends Date" need centering in the column.

    N. Bids should be replaced with "Total Bids" or "Number Of Bids"

    Max. Bid Should be replaced with "Current Bid" as it is displaying the "Current Bid" of the item and not the user's "Maximum Bid"
     
    Last edited: Apr 1, 2016
  7. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    I am currently working on the above but need some advice please.

    In the language file messages.inc.php under the your auctions page heading as well as in a lot of the other messages inside messages.inc.php I am seeing a lot of %s in the language strings can someone please tell me what all the %s are about or explain what they do please a quick google only turns up stuff about PHP's printf and sprintf.

    I am not being funny here but I think that the messages.inc.php was already confusing enough for novices of WeBid who wanted to change or alter a text string without all of the new and added %S's that are now cutting words out of sentences and cutting sentences short.
     
    Last edited: Apr 1, 2016
  8. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    the %s is used in printf which is the best way to push words into a sentence %s is a type flag meaning a string goes here can also be %d for number. Theres no real way to do this without rewriting large chunks of how the translations work unfortunatly
     
    nay27uk likes this.
  9. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Ok thanks Renlok I think it was a lot easier for people to understand the old way though.
    How do I find out exactly what word in the sentence is being replaced by %s are they stored somewhere?
     
  10. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Pull Request now submitted.

    Below are a few screen shots of how the yourauctions page now looks after the changes submitted in the pull request.
    In red arrow in the pictures points to the new icons with tooltips you will also notice changes to the column data and column headings on the table (not arrowed but just compare the old with the new)

    Classic Theme
    edit_Clasic.jpg
    Modern Theme
    edit modern.png
     
    Last edited: Apr 2, 2016
  11. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Still testing stuff out so expect more posts here in this thread and maybe some more commits.

    I still need to check the admin side as I still think that the Logo Upload Via Admin MOD that lots of people have requested and that was submitted by me to the git and then improved on by the other member and that was finally accepted and merged has now disappeared from the WeBid admin again.

    I could be wrong on that but I haven't really played with the admin side yet apart from changing the uploaded image size, turning off template cache, and switching themes.

    Talking in my above paragraph about the image upload size recalls my memory to a post Mark Lamberson made about the fact that all uploaded images are being resized to 600px, I am not sure if you read that thread Renlok but it is something I think needs to be fixed.
    There should be at a minimum a setting in admin where the admin can set the dimensions for resizing of uploaded images, as it stands all images are automatically resized to 600px the admin needs to be able to set this size without having to open a PHP file and change PHP code.

    The original thread about this little problem can be found HERE
     
    Last edited: Apr 3, 2016
  12. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Anybody HERE?

    THIS POST HERE needs to be sorted out and sorted out quickly before this WeBid is released into the public domain.

    I have tried but half of the div ID's, Div Classes, Heights and Widths have all been replaced with %s and %d.

    Where exactly in securimage.php is it pulling its %s, %d from for the Div Class, Div Id's and Widths and Heights?

    I have tried everything now in securimage.php by adding my own new DIVS and removing all align lefts or adding align Centers or text-align: centers to my new DIVS, but I have ran out of ideas now as I do not know what file or files the DIV IDs, DIV CLASSEs or HEIGHTs or WIDTHs or being pulled from, I have checked every single file in the captcha folder as well as the WeBid CSS I can't find them anywhere not at all.

    The captcha needs center aligning like the rest of the register page form is in the classic theme.

    This may seem like me being too overzealous but I can 100% guarantee that when this is released as it stands now that there will be a myriad of members asking "How do I center align the captcha like the rest of the page is?" it is better that this be resolved NOW rather than a million posts on the forums later that are all asking the same question.

    I am testing this new version while I am thinking about all the Questions that have been asked since my signing up here and all the questions that will be asked in the future on the forums.

    It is imperative that we keep all of the future questions or threads to a minimum and this is one of those questions that I know for a fact will crop up over 50 times in about 12 months.

    This new version of WeBid MUST BE the FIRST EVER NON BETA, NO NEEDED THEME TWEAKS, 100% BUG FREE, version of Webid ever released and at the moment from my testing it is only around 50% completed.

    Things like the silly alignment of the captcha above that if one tries to alter himself and it does not work because of some DIV CLASS or DIV ID or Height or Width elements that are now hidden in the layout by %s or %d is all holding the script back from being exactly what I said above.

    This needs sorting and sorting promptly.
     
    Last edited: Apr 4, 2016
  13. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    hey sorry been really busy over the last few days I'm not 100% sure how the securimage.php works I think LOD updated it to a newer version and I haven't looked at it since but when I get a few hours to spare I'll get it sorted and go through the bugs/fixes you've found.

    Also for the point you brought up about the %s in the language strings I think you're right I will look into doing it another way but that will involves writing a whole new language system, which I would prefer to do after this version is released. I have used laravel in the past and it has a really nice way to deal with translations I might try and copy their style https://laravel.com/docs/master/localization#basic-usage
     
  14. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Thanks renlok and sorry if I sounded a bit off in any way above as I am not trying to be mate I am just passionate about webid and as so I am stepping in to other members shoes as well as my own, I know that I can sound a bit blunt sometimes but I assure you that is just passion.

    The %s and %d was a good idea but from a new member perspective I'm unsure however if they have to stay then so be it and I am sure someone would be kind enough to write a thread or documentation that would point out where each one are being pulled and replaced from.

    I will take a read of that new language script and see if I can get my head round it because I would love to help out but unfortunately as you all know I am unless with code unless it is theme related as any other code just goes in one ear and straight out of the other.

    Is there anything I could do that may help?

    Good luck with secureimage.php because I have ran out of ideas as to where all of the styling for its divs are coming in from apart from a bit being inline styling.

    Anyway I hope you understand that I am just passionate about this new release and not nit picking I just wish I could help more.
     
    Last edited: Apr 5, 2016
  15. super_st

    super_st Well-Known Member

    Joined:
    Dec 2, 2012
    Messages:
    634
    Likes Received:
    141
    Sorry not had much time to help out with tests recently, been busy.

    Would be nice to see on the 'browse' page the column 'ends in' to change this from a date to days left. Basically like the end within code on item page.

    so change from : Closes on 24 Apr, 2016 - 19:59
    to: 18 days left

    then a count down for the last 24hr.
     
    renlok and nay27uk like this.
  16. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Next one is.

    There are still no SEO URL's that where promised for this version :(
     
  17. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    Awesome work guys :) I have fixed all the bugs you've picked up so far. And I'm not sure what happened to the logo upload all the language string all still in the language file but I cant find it in admin any more :/

    And in terms of the SEO urls I did start working on it a few months ago https://github.com/renlok/WeBid/com...2afb9ad#diff-c5005514d027113e9e6240f2e04bf29d but I realised it would involve reorganising the entire file structure on top of a lot of template edits (to do it properly would take a while, I am also planning on doing a rewrite of the template engine so its easier to use for next release so I dont want to have to rewrite templates twice) and I want to focus on bugs and get this release out asap. The SEO mods is a substantial amount of work not the same level as the PDO convertion which took me about 2 years (with lots of breaks) but a good few weeks of effort
    But when I release 1.2 I can quickly put together a mod to get SEO urls in it but the template edit would still need to be made manually

    Back in the dark ages each page had its own rewrite rule so a big project would have tons of .htaccess rules the modern way to deal with it is to make all requests go through the index.php page and let index.php pull the page you want so you only need one rewrite rule and you can add as many pages as you want with no problem (you can see that happening on this forum if you browse different pages each contains index.php)
    so the root directory only has index.php and all other pages are in a subdirectory then with SEO disabled the url would be mysite.com/index.php?item/1/auction_name123 with it enabled it would be mysite.com/item/1/auction_name123
     
    nay27uk likes this.
  18. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Nice work ten sounds good to me.
    If you need a copy of logo upload let me know I have it on the pc
     
  19. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
  20. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Yeah it is I forgot I put it back on the forum that should have the delete feature in it as well mate
     

Share This Page