1.2 rc5

Discussion in 'Testers' started by renlok, Sep 3, 2014.

  1. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    DO NOT RUN THIS ON A LIVE SITE

    DO A FRESH INSTALL WITH EACH NEW VERSION, UPDATING BETWEEN TEST BUILDS MAY BREAK THEM


    Well there is a hell of a lot todo before we can release version 1.2 but a lot of work has been done with little testing so it would be useful for me for a few people to have a look at whats done so far to see if it works as it should also to get feedback on what needs doing.

    There is also 86 active bug reports at http://bugs.webidsupport.com/ I want this to be less than 10 before 1.2 can be released

    Current progress with PDO conversion: COMPLETE
    Progress in fixing how the translations work: http://webidsupport.com/forums/inde...ng-how-to-better-deal-with-translations.8458/
    Current TO DO list: https://github.com/renlok/WeBid/wiki/To-DO (not everything will get done before 1.2, 1.2 will be released with PDO conversion is completed and only a few bugs remain)

    Download most recent build: https://github.com/renlok/WeBid/archive/master.zip

    rc1 = commit 472
    rc2 = commit 513
    rc3 = commit 564
    rc4 = commit 977
    rc5 = commit 1013
     

    Attached Files:

    Last edited: Apr 24, 2016
    david62311 and nay27uk like this.
  2. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    I will install later and give it a test.
    Also sent a pull request that removes some of the styling out of the PHP and into the CSS this makes it easier for themers to re theme WeBid and means less core file inludes if any at all when releasing a theme
     
  3. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    oh ok awesome I'll have a look later didn't notice it before
     
    nay27uk likes this.
  4. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    Could I ask that you add to the TO DO list here SEO friendly URL's.

    Pho3nix SEO mod is about the best starting point for that as it is almost 100% the hole of WeBid but with some pages not done.
     
    Last edited: Sep 4, 2014
  5. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,165
    Likes Received:
    251
    It's missing includes/countries.inc.php(it's in red) and there is no install button showing because that file is missing. I just added the includes/countries.inc.php from the Webid 1.1.1 version and the install button appeared after that.

    I am kind of new to installing scripts manually. I tried to follow these instructions but, I lack attention to detail or something.
    http://www.webidsupport.com/wiki/Installation . I had an existing database but, one I just installed fresh from a Webid 1.1.1 version. I am having trouble with the user name and password.

    Any quick tips on installing this?

    Whoops, that photo was supposed to be removed.

    Update: Nevermind on helping me with the database. It's just been years since I created one from scratch. I will have it working soon.
     

    Attached Files:

    Last edited: Sep 5, 2014
  6. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,165
    Likes Received:
    251
    On the to do list, I got my Español to work and it seems to stay in the language I choose even after I log out and log back in later or on another PC. It even emails me in Spanish when my items close.

    I used this solution at post#3 to make it stop switched back to English every time I clicked a tab. It should work the same for all languages. It's for the includes/messages.inc.php file.
    Problem With Language Changing Solution

    The only weird thing is that if I log into the admin panel later or at the same time using the same PC, the session is still set for me to be in Spanish. It would be nice if that only happens for the user or vice versa the admin when using the same Device or PC and not both. I know it's because I am on the same computer that it does that but, it is annoying.
     
    Last edited: Sep 6, 2014
  7. dcobain

    dcobain New Member

    Joined:
    Aug 12, 2014
    Messages:
    85
    Likes Received:
    9
    i have given it a fast try.

    email registration works fine
    new user welcome email work fine
    auction confirmation works fine

    I just added the includes/countries.inc.php from the Webid 1.1.1 version , too

    On Installation the text is: WeBid Installer v1.1.0

    In Admin CP :You are running an old version you can download the latest version from here 1.1.0 (1.1.1)

    in Tools:
    (This error comes always)
    Unknown error type: [8] Undefined offset: 3 on C:\Program Files\Ampps\www\webid112\includes\class_db_handle.php line 75
    Unknown error type: [8] Undefined offset: 4 on C:\Program Files\Ampps\www\webid112\includes\class_db_handle.php line 75

    I have seen you have changed some code. line 75 is similar to ver 1.1.1. i couldnt figure out why there is an error in line 75
    (i searched for this error with google)

    Thes error comes when you start/ save an auction bn
    Unknown error type: [8] Undefined index: SELL_additional_shipping_cost on \includes\functions_sell.php line 45
    Unknown error type: [8] Undefined index: ATYPE_PLAIN \includes\template.php(165) : eval()'d code line 194
    Unknown error type: [8] Undefined index: ERROR on includes\template.php(165) : eval()'d code line 208

    Auctions are not shown in mainpage

    in user CP: error in: yourauctions.php on line 102 when i tried to see selling items

    Thats it for now.

    with kind regards
     
    Last edited: Sep 11, 2014
    renlok likes this.
  8. david62311

    david62311 Well-Known Member

    Joined:
    Aug 29, 2013
    Messages:
    2,165
    Likes Received:
    251
    @dcobain It's on the to do list: Convert all mysql_ to use db class. It's not ready yet.
     
    Last edited: Sep 15, 2014
  9. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    Yeah you'll get this error for all test releases as its not counted as a proper release
     
  10. nteller

    nteller New Member

    Joined:
    Sep 18, 2014
    Messages:
    1
    Likes Received:
    0
    Is there a kind of list, what schould be tested ?
     
  11. nay27uk

    nay27uk Super Moderator Staff Member

    Joined:
    Nov 24, 2009
    Messages:
    5,573
    Likes Received:
    550
    No just test everything and report back any problems
     
  12. athera

    athera Active Member

    Joined:
    Jul 10, 2014
    Messages:
    282
    Likes Received:
    40
    1.2 fails to save auction to the DB

    admin side
    seems to work OK

    user side
    user gets created
    sell.php fails to save auction to the DB

    I added an auction to the DB manually
    then
    auction appears in auctions list
    bids can be placed

    cron seems to close auction as expected

    I tried looking in functions_sell addauction for errors
    but it tells me that both

    $db->setAttribute()
    $db->errorInfo()

    are not implemented

    any way

    echo $query; and print_r($params); seem to have the correct data

    no idea why $db->query($query, $params); fails

    We really need to get this resolved before we can effectively test further

    Does anybody have any ideas???
     
  13. super_st

    super_st Well-Known Member

    Joined:
    Dec 2, 2012
    Messages:
    634
    Likes Received:
    141
    If this is the latest testing thread,
    Unstalled fresh from github. I know theres probs lots to do but heres a few issues:
    Currently struggling to even log in in front end, and lots of issues in admin to do with users
    Made a pull request on github
    other issues
    - Missing countries.in.php
    - log error -
    Code:
    SELECT can_sell, can_buy FROM webid_groups WHERE id IN () AND (can_sell = 1 OR can_buy = 1) You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ') AND (can_sell = 1 OR can_buy = 1)' at line 1 page:/home/caredgec/public_html/auction/includes/class_user.php line:51
    -
    Code:
    Unknown error type: [8] Array to string conversion on /home/caredgec/public_html/auction/cache/tpl_admin_sidebar-auctions.tpl.php line 16
    -
    Code:
    Unknown error type: [8] Undefined offset: 3 on /home/caredgec/public_html/auction/includes/class_db_handle.php line 75 
    12-04-2015, 00:24:28: Unknown error type: [8] Undefined offset: 4 on /home/caredgec/public_html/auction/includes/class_db_handle.php line 75
     
  14. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    I think I have fixed all of these problems now
     
  15. super_st

    super_st Well-Known Member

    Joined:
    Dec 2, 2012
    Messages:
    634
    Likes Received:
    141
    Ok thanks

    Next issues i see may be to do with this fix. I can now login front end as user. there are no sell item link in navbar, and no selling section in control panel.
    I checked to make sure i was added as able to sell in admin panel. Which i wasnt, so i go to edit user php in admin and there are no checkboxes to click to ad me to either group.

    **I am now going to try and add a new user see if this works.(edit. did not join new user to any user group)

    also get this error
    Code:
    14-04-2015, 15:51:11: Unknown error type: [8] Undefined offset: 3 on /home/caredgec/public_html/auction/includes/class_db_handle.php line 75
    14-04-2015, 15:51:11: Unknown error type: [8] Undefined offset: 4 on /home/caredgec/public_html/auction/includes/class_db_handle.php line 75
    and these
    Code:
    Unknown error type: [8] Use of undefined constant error - assumed 'error' on /home/caredgec/public_html/auction/cache/tpl_default_confirm.tpl.php line 7
    14-04-2015, 16:05:08: Unknown error type: [8] Use of undefined constant confirm - assumed 'confirm' on /home/caredgec/public_html/auction/cache/tpl_default_confirm.tpl.php line 11
    14-04-2015, 16:05:08: Unknown error type: [8] Use of undefined constant confirmed - assumed 'confirmed' on /home/caredgec/public_html/auction/cache/tpl_default_confirm.tpl.php line 20
    cant access admin/auctions.php
    Code:
    Parse error: syntax error, unexpected ')' in /home/caredgec/public_html/auction/admin/auctions.php on line 62 
     
    Last edited: Apr 14, 2015
  16. super_st

    super_st Well-Known Member

    Joined:
    Dec 2, 2012
    Messages:
    634
    Likes Received:
    141
    Issues as above and also:

    - countries data missing in admin/countries,php (no data in tables)
    - added a news item in admin, in admin/news.php says '1 news items found in the database' yet the table list underneath is empty.
     
  17. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    OK i think I found most of the problems with PDO is because fetch() is being used outside of a while loop which breaks the code because fetch() is made to only be used inside a loop so f it isnt it thinks its in a loop that never finishes and breaks everything
     
    super_st likes this.
  18. super_st

    super_st Well-Known Member

    Joined:
    Dec 2, 2012
    Messages:
    634
    Likes Received:
    141
    Great, a few updates there. I will add all these changes tomoz/early next week and see where we are at
    Be prepared for the next list LOL
     
  19. super_st

    super_st Well-Known Member

    Joined:
    Dec 2, 2012
    Messages:
    634
    Likes Received:
    141
    Heres a few errors.
    Code:
    Unknown error type: [8] Undefined variable: balance on /home/#####/public_html/auction/admin/edituser.php line 171
    27-04-2015, 16:04:39: Unknown error type: [8] Undefined index: on /home/#####/public_html/auction/includes/class_db_handle.php line 172
    27-04-2015, 16:04:39: Unknown error type: [8] Undefined offset: 2 on /home/######/public_html/auction/includes/class_db_handle.php line 75
    27-04-2015, 16:05:29: Unknown error type: [8] Undefined index: SELL_additional_shipping_cost on /home/#####/public_html/auction/includes/functions_sell.php line 45
    27-04-2015, 16:05:40: Unknown error type: [8] Array to string conversion on /home/#####/public_html/auction/upldgallery.php line 281
    27-04-2015, 16:05:40: Unknown error type: [8] Array to string conversion on /home/#####/public_html/auction/includes/template.php(165) : eval()'d code line 101 
    I also notice regarding the groups issue.
    1/ Sign up as new user, this now adds them to the groups. :D
    2/ Tried to add my old users to the groups but it does not save the changes.

    Creating auctions
    --
    also does not set up auction, it does say there is one live auction but theres no recollection to this in either admin/ user. Even said it was auction #0 lol did get an invoice for it though haha
    -- added second auction, this also classed as #0 also does not show, upload picture link shows as broken image. Upload file '0' is added to uploaded file in cpanel but no image uploaded

    Looks like its maybe not adding auc_id correctly,

    Will add more to this list as i find :D

    get theis aswell in user panel auction pages
    Code:
    Fatal error: Unsupported operand types in /home/caredgec/public_html/auction/yourauctions_s.php on line 83
     
    Last edited: Apr 27, 2015
  20. super_st

    super_st Well-Known Member

    Joined:
    Dec 2, 2012
    Messages:
    634
    Likes Received:
    141
    Yeah can now create auctions after github up date. :D

    Still have issues in selling pages (frontend) eg in all yourauctions php pages
    Code:
    Fatal error: Unsupported operand types in /home/*******/public_html/auction/yourauctions.php on line 102
    Image upoad still not working (maybe panis fix in the security 1.1.2 thread may help with this)

    Some errors reagarding i believe when i tried to change and save users joined group in admin
    Code:
    07-05-2015, 15:58:20: Unknown error type: [8] Undefined variable: balance on /home/****/public_html/auction/admin/edituser.php line 171 
    07-05-2015, 15:58:20: Unknown error type: [8] Undefined index: on /home/****/public_html/auction/includes/class_db_handle.php line 172 
    07-05-2015, 15:58:20: Unknown error type: [8] Undefined offset: 2 on /home/****/public_html/auction/includes/class_db_handle.php line 75
    and these:
    Code:
    07-05-2015, 16:01:35: Unknown error type: [8] Undefined index: worldpay_id on /home/****/public_html/auction/admin/fees.php line 179 
    07-05-2015, 16:01:36: Unknown error type: [8] Undefined index: toocheckout_id on /home/****/public_html/auction/admin/fees.php line 179
     

Share This Page