0.7.0

Discussion in 'Testers' started by renlok, Nov 19, 2008.

  1. eben80

    eben80 New Member

    Joined:
    Oct 31, 2008
    Messages:
    9
    Likes Received:
    0
    Re: 0.7.0 [WIP]

    I'm getting the same.. the D: symbol... in some instances.
    I also found that If you try to relist an item it takes up the id of an existing active auction and replaces it.
     
  2. jmorris1161

    jmorris1161 New Member

    Joined:
    Nov 19, 2008
    Messages:
    73
    Likes Received:
    0
    Re: 0.7.0 [WIP]

    Ok, I think I got it (The D: on listing an item )fixed. I counted the fields in the error log it was trying to post 30 fields to the DB the DB however had 31 in auctions table. So I took out the shipping_cost and it works. I will test further to make sure it does everything right but it looks like it works. I know in selling an item there is never a place to put in Shipping Cost so evidently that hasn't been implemented in the code yet so the php does not push it to the DB.
     
  3. jmorris1161

    jmorris1161 New Member

    Joined:
    Nov 19, 2008
    Messages:
    73
    Likes Received:
    0
    Gallery Picture

    I can upload a picture, and gallery pictures, but it is not showing the gallery thumbnail picture besides the auction title in the category or subcategory directories.

    As a side note, it would also be nice to see the gallery thumbnail pictures on the main page too where it shows latest and soonest ending items.
     
  4. jmorris1161

    jmorris1161 New Member

    Joined:
    Nov 19, 2008
    Messages:
    73
    Likes Received:
    0
    Pictures on re list

    I put up a listing with a picture, then ended it and did a re list but it doesn't remember the picture. Not a huge problem but it is a pain to have to find the picture again for sellers when they re list an item.
     
  5. jmorris1161

    jmorris1161 New Member

    Joined:
    Nov 19, 2008
    Messages:
    73
    Likes Received:
    0
    Feedback Problems

    Ok, there is a problem in feedback. The php uses 'comment' the database uses 'feedback'

    I changed in feedback.php

    This
    $sql = "INSERT INTO ".$DBPrefix."feedbacks (rated_user_id, rater_user_nick, comment, rate, feedbackdate, auction_id) VALUES (

    To this
    $sql = "INSERT INTO ".$DBPrefix."feedbacks (rated_user_id, rater_user_nick, feedback, rate, feedbackdate, auction_id) VALUES (

    In yourfeedback.php

    From
    $feed_disp[$i]["feedback"] = nl2br(stripslashes($arrfeed['comment']));
    To
    $feed_disp[$i]["feedback"] = nl2br(stripslashes($arrfeed['feedback']));

    ren if you can think of any other places where comment was used instead of feedback please let us know. I figured it was better to change the code than change the DB name. That way your references stay the same.
     
  6. jmorris1161

    jmorris1161 New Member

    Joined:
    Nov 19, 2008
    Messages:
    73
    Likes Received:
    0
    relist auction id replacement

    Yep, it does take the place of the id for the last auction listed. I haven';t figured this out yet, hopefully ren has a quick fix.. ;-)
     
  7. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    Re: 0.7.0 [WIP]

    i searched the site and the comment thing isn't used anywhere else

    And ive found the problem with the relist and heres the fix open relistauction.php
    and change
    Code:
    $_SESSION["SELL_auction_id_old"]
    to
    Code:
    $_SESSION['SELL_auction_id']
     
  8. jmorris1161

    jmorris1161 New Member

    Joined:
    Nov 19, 2008
    Messages:
    73
    Likes Received:
    0
    Listing losing picture after going back form confirm

    When you are listing an auction and upload a picture, do every thing else, then on the next page click on make changes it goes back but doesn't remember the picture so you have to upload it again.
     
  9. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    Re: 0.7.0 [WIP]

    yeah i know thats a pain but i dont know how to fix that, what im going to do when i get round to it is merge the gallery and image upload together with a javascript/flash image uploader
     
  10. jmorris1161

    jmorris1161 New Member

    Joined:
    Nov 19, 2008
    Messages:
    73
    Likes Received:
    0
    Re: Gallery Picture


    I think I found the problem, but not the answer yet. I get this in my log

    [08-Dec-2008 08:11:01] PHP Warning: fopen(36.jpg) [function.fopen]: failed to open stream: No such file or directory in W:\www\myeauctions\lite\getthumb.php on line 21

    [08-Dec-2008 08:11:01] PHP Warning: Cannot modify header information - headers already sent by (output started at W:\www\myeauctions\lite\getthumb.php:21) in W:\www\myeauctions\lite\getthumb.php on line 8

    for every listing in a category that has a picture when I go into that category.

    ---- MORE INFO ADDED ------
    If you list an auction with a url for the picture it shows but not for ones that are uploaded.
     
  11. jmorris1161

    jmorris1161 New Member

    Joined:
    Nov 19, 2008
    Messages:
    73
    Likes Received:
    0
    Title in Category view doesn't like special characters

    I have noticed some thing like ( ) # etc show funn yin the category listing.

    Here is one form category view
    Genuine Tanzanite Oval Lot (3) 7x5mm 1.90CTW

    Same one from the front page view under ending soon
    Genuine Tanzanite Oval Lot (3) 7x5mm 1.90CTW
     
  12. renlok

    renlok Administrator Staff Member

    Joined:
    Oct 20, 2008
    Messages:
    2,858
    Likes Received:
    330
    Re: 0.7.0 [WIP]

    ah yes for some reason htmlspecialchars is used on the titles on the browse page heres the fix

    open includes/browseitems.inc.php
    find
    Code:
    $tplv['idformat'] .= stripslashes(htmlspecialchars($row['title']));
    replace with
    Code:
    $tplv['idformat'] .= stripslashes($row['title']);
     
  13. wvpdles

    wvpdles New Member

    Joined:
    Nov 22, 2008
    Messages:
    12
    Likes Received:
    0
    Re: Pictures on re list


    open relistauction.php
    after lines:
    Code:
      $_SESSION["SELL_title"]         = $RELISTEDAUCTION['title'];
      $_SESSION["SELL_description"]     = $RELISTEDAUCTION['description'];
    
    add:
    Code:
       $_SESSION["SELL_pict_url"]         = $RELISTEDAUCTION['pict_url'];
    

    then open template_sell.php.html
    find
    Code:
                                <input type="text" size=40 name="pict_url" value="<?=$pict_urlH; ?>" onFocus="document.sell.imgtype[0].checked='true';"/>
    
    replace with
    Code:
                                <input type="text" size=40 name="pict_url" value="<?=$pict_url; ?>" onFocus="document.sell.imgtype[0].checked='true';"/>
    
     

Share This Page