PDA

View Full Version : Miscellaneous Errors



zachakamp
08-01-2009, 07:53 PM
When I first installed the software, everything went fine until right before setting up the admin account. I got the following error:
Warning: include(/home/lincolo0/public_html/auction/includes/maintenance.php) [function.include]: failed to open stream: No such file or directory in /home/lincolo0/public_html/auction/includes/config.inc.php on line 40
Warning: include() [function.include]: Failed opening '/home/lincolo0/public_html/auction/includes/maintenance.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/lincolo0/public_html/auction/includes/config.inc.php on line 40
I had to end up manually creating an empty 'maintenance.php' file in the 'includes' folder - this made the error go away and I was able to complete the installation.

Another problem is when I try to edit an auction. I get the following error:
Warning: opendir(/home/lincolo0/public_html/auction/uploaded/2) [function.opendir]: failed to open dir: No such file or directory in /home/lincolo0/public_html/auction/edit_active_auction.php on line 129
Warning: readdir(): supplied argument is not a valid Directory resource in /home/lincolo0/public_html/auction/edit_active_auction.php on line 130
Warning: closedir(): supplied argument is not a valid Directory resource in /home/lincolo0/public_html/auction/edit_active_auction.php on line 138
Warning: Cannot modify header information - headers already sent by (output started at /home/lincolo0/public_html/auction/edit_active_auction.php:129) in /home/lincolo0/public_html/auction/edit_active_auction.php on line 160
I have to manually create a subfolder under the 'uploaded' folder with the number of the auction in order for it to work.

Also, sometimes when I try to upload a picture to an auction, it seems to work, but I get the following error:
Warning: unlink(/home/lincolo0/public_html/auction/uploaded/9ad87e3c2eab6f8134d05ae3e49f27ed/) [function.unlink]: Is a directory in /home/lincolo0/public_html/auction/upldgallery.php on line 59

These are the only errors I've run into so far, so please let me know what I need to do to correct them. If this information helps: I'm running Apache 2.2.11 on Linux, PHP version 5.2.8, and mySQL version 5.0.67-community-log.

Aside from the errors, I would also like to know how I can change the shipping condition options to 'Seller will deliver' and 'Buyer must pickup'. I'm setting up a local auction site, thus I would also like to remove the option for shipping fee and the links for currency converter.

jbilliau
08-01-2009, 07:55 PM
Sounds like you didn't set permissions.

zachakamp
08-01-2009, 09:03 PM
I checked my permissions against the readme file, and I even tried reinstalling; but all of the errors remain.

jbilliau
09-01-2009, 02:02 PM
Your running the newest build correct? Did you check the permissions on the sub folders within the uploads dir?

zachakamp
09-01-2009, 08:50 PM
I just installed the latest build. I will see if that fixes everything.

Uldtot
09-01-2009, 08:59 PM
had same error with the mainteance.php. did samae to "fix" it.